【Sass】macOS High SierraでKoala/Dreamweaverがコンパイル出来なくなったら

  • CSS
【Sass】macOS High SierraにしたらKoala/Dreamweaverでコンパイル出来なくなった

Koalaがご機嫌斜め!

先日、macOS High Sierraにアップグレードしたら、
KoalaでSassのコンパイルが出来なくなってしまいました。

どうやら High Sierra で Ruby のバージョンが、変わったことが原因のようです。

検索すると情報は少ないですが、下記ページが出てきました。

Doesn’t compile SCSS after update OSX to 10.13 (macOS High Sierra)

解決方法

1. Xcodeをインストール

App Storeを開いてXcodeをインストールします。
App Storeからダウンロードしたままではインストールが済んでいませんので、
Xcodeを立ち上げてインストールを完了させてください。

2. Homebrewをインストール

ターミナルを開いて下記を実行します。
※Homebrewをインストール済みの方はこの項はスキップしてください。

$ ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

3. rubyをインストール

$ brew install rbenv ruby-build

4. Sassをインストール

$ sudo gem install -n /usr/local/bin sass

以上で、Koala/DreamweaverでのSassコンパイルが正常に動くようになりました。

Writer

ko

KO

誕生日に会社のみんなから『世界文学全集』をプレゼントしてもらった読書好きフロントエンド・エンジニアです。WordPressとMovableTypeが得意ですが、本当の特技は薪割りです。

Page Topへ